Usenet Explorer
http://usenetexplorer.com/forum/

UE Running on Ubuntu (Linux)
http://usenetexplorer.com/forum/viewtopic.php?f=11&t=7681
Page 1 of 2

Author:  LarryM [ Sun Aug 06, 2017 8:24 pm ]
Post subject:  UE Running on Ubuntu (Linux)

I've "officially" switched using UE from a Win7 PC, to my brand new Ryzen 7 powered PC using Ubuntu 17.04 as the OS. I'm using CrossOver which provides a front-end to Wine and presents a Win7 environment to UE. I have the UE database on a SSD drive, so yes the system flies.

I'm happy to report that with exception of a couple little quirks UE works fine.

The quirks that I've uncovered so far: if I split the newsgroup view on a text item, the screen is a bit scrambled, but opening on a jpg and the screen is fine. The other is that when I open a news group its tab opens to the left of the previously active tab, in windows it opened to the right.

Anybody else using UE on a Linux variant?

Author:  LarryM [ Tue Aug 08, 2017 4:59 pm ]
Post subject:  Re: UE Running on Ubuntu (Linux)

I guess the split newgroup sceen is a little more than "slightly scrambled" If the text is more than one line, its pretty un-readable.

Any chance you could do anything to help this out Alex?

Author:  LarryM [ Wed Aug 09, 2017 3:21 am ]
Post subject:  Re: UE Running on Ubuntu (Linux)

One other thing - when I attempt a download, choosing the folder to put the parts in has a problem as it can't seem to create a new folder. Going into an existing folder is fine, but creation part seems to not do anything.

Author:  LarryM [ Wed Aug 09, 2017 9:34 pm ]
Post subject:  Re: UE Running on Ubuntu (Linux)

Okay, I revise my description of the split screen being "scrambled". What it actually look like is some of the screen that was behind it didn't get erased. See screen shot.

Larry

Attachments:
UE_Screen_Shot.png
UE_Screen_Shot.png [ 35.34 KiB | Viewed 10555 times ]

Author:  Glamdring [ Fri Aug 11, 2017 5:10 pm ]
Post subject:  Re: UE Running on Ubuntu (Linux)

When I tried UE on Linux (Debian Jessie with 64bit Wine) the program crashed when detecting a rar set protected by a password, while importing a nzb file.

You seem to be running the latest version of Ubuntu, could you verify if this (crash password protected rar) is still happening?

Author:  LarryM [ Sat Aug 12, 2017 1:14 pm ]
Post subject:  Re: UE Running on Ubuntu (Linux)

Well, that's a pretty specific circumstance, one I don't have right now, but I can tell you that it does deal with passworded posts just fine. I just don't have an NZB to one. I'll keep my eyes open tho.

Also, I'm using a program called CrossOver. Its a front end/packaging for Wine. Its paradigm is to use "bottles". You create a bottle in the version of Windows you wish to emulate (WinXP, Win7 32bit, Win10 64 bit, etc) then install the windows program you wish to run into this bottle. Its sort of a WM. The cool part is that anything the windows program does is limited to its bottle, so no matter how much it runs amok, its contained. Also makes the uninstall complete - just delete the bottle.

Author:  LarryM [ Sat Aug 12, 2017 1:37 pm ]
Post subject:  Re: UE Running on Ubuntu (Linux)

A little more expansion on one of the difficulties - if I attempt to download and save, the dialog pops up with the file tree at the default folder. That's fine, but if I want to save in a sub-directory and I add a folder name, the folder doesn't get created and UE saves the file in the default folder.

Not the end of the world, but I use the default folder as a starting point, creating sub- and sub-sub-folders. So I have to keep popping out of UE, creating the folder in the file manager, then go back into UE and do the save. Like I say, not the end of the world, but I'm hoping Alex can tweak something and provide some relief for this.

Author:  LarryM [ Sat Aug 12, 2017 8:36 pm ]
Post subject:  Re: UE Running on Ubuntu (Linux)

Okay, happy to report that an attempt to use an NZB to download a password protect post worked just fine. It rejected the download as expected.

Author:  Glamdring [ Sun Aug 13, 2017 6:03 pm ]
Post subject:  Re: UE Running on Ubuntu (Linux)

Larry,

Are you using the 32bit executable of UE? I am trying crossover and the 64bit version just won't run.

However, UE 32bit runs just fine.

Author:  LarryM [ Sun Aug 13, 2017 7:51 pm ]
Post subject:  Re: UE Running on Ubuntu (Linux)

Well, there are so many variables. I'm using:
Ubuntu 17.04
CrossOver 16.2.5
In CrossOver I'm using a WinXP bottle
UsenetExplorer 5.0.3, 32-bit

But I also ran UE as a 64-bit program in a Win7-64 bit bottle, it ran fine too.

Previous to this "official" install I did a trial install of 64 bit UE directly in Wine on my laptop. I didn't copy over the database, but it did start up and got headers for a newgroup I set up

What kind of problem are you seeing? What sort of bottle are you using in CrossOver?

Author:  Glamdring [ Sun Aug 13, 2017 8:01 pm ]
Post subject:  Re: UE Running on Ubuntu (Linux)

I am using:

Debian Stretch 9.1
CrossOver 16.2.5
Bottle Win7 32bit
UE 5.0.3 32bit

Runs fine.

However, the UE 64bit version in a Win7 64bit Bottle ran fine the first time, but gives a Wine crash on subsequent runs.

Author:  LarryM [ Sun Aug 13, 2017 8:17 pm ]
Post subject:  Re: UE Running on Ubuntu (Linux)

Well, 32 bit it is then.

Do you have problem with displaying a downloaded text message? (See screen shot way above)
Can you create a folder and download an article to it? The folder has to pre-exist for me, UE won't create it.

Author:  LarryM [ Sun Aug 13, 2017 8:21 pm ]
Post subject:  Re: UE Running on Ubuntu (Linux)

The whole Wine/CrossOver thing is handy, but not a guaranteed thing...

I have a program - DVDFab that recently came out with a Liunx version (yay!) Oddly, it won't run if I'm using the proprietary nVidia driver for my video card, only if I use the generic driver. Another program I have in CrossOver is Xilisoft's Video Converter, it will only run if I use the prop driver, not the generic one. Hopefully the DVDFab people will correct this error on their next release.

Author:  Glamdring [ Sun Aug 13, 2017 9:19 pm ]
Post subject:  Re: UE Running on Ubuntu (Linux)

Well, I don't use UE for text newsgroups. So I can't help you with that. Have you tried configuring Wine not to let the window manager handle the graphics things?

I mainly import NZB's with the auto option, so a folder gets created after the NZB name. This works for me.

Author:  LarryM [ Mon Aug 14, 2017 4:19 am ]
Post subject:  Re: UE Running on Ubuntu (Linux)

Good idea about the graphics/window manager, but it didn't help.

Page 1 of 2 All times are UTC
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/