Usenet Explorer

Forums
It is currently Tue Aug 21, 2018 10:19 pm

All times are UTC




Post new topic Reply to topic  [ 9 posts ] 
Author Message
 Post subject: Search Service showing huge amount of incomplete parts
PostPosted: Sun Feb 05, 2012 1:32 pm 

Joined: Mon Apr 04, 2005 7:15 pm
Posts: 7
Hi Alex,

How are you doing?

Just wondering, is there currently something wrong with Usenet Explorer's Search Service? Over the past days I noticed a relatively huge amount of incomplete parts, as shown by Usenet Explorer's Search Service. However, when I verified the same posting by using a different NZB index service, the posting was complete. Moreover, I was able to download the complete posting (after importing the NZB file in Usenet Explorer from the NZB index service) without any problems whatsoever, as opposed to when I tried to download the same posting based on Usenet Explorer's Search Service results, in which case there were not enough recovery files available.

Example:
"American Idol S11E06 720p DD5.1 448kbps-ALANiS.ts"

Please find attached two screen dumps plus the actual NZB file I used, which will provide you with further details.

Could you please investigate?

Thanks in advance!

P.S. I am a subscriber to Giganews and Newscene.

Kind Regards,
Victor Alberts.


Attachments:
File comment: American Idol S11E06 720p DD5.1 448kbps-ALANiS.ts.txt.nzb (zip)
American Idol S11E06 720p DD5.1 448kbps-ALANiS.ts.txt.zip [163.51 KiB]
Downloaded 339 times
File comment: Different NZB index service - All Complete
Different NZB index service - All Complete.jpg
Different NZB index service - All Complete.jpg [ 136.87 KiB | Viewed 7360 times ]
File comment: Usenet Explorer's Search Service - Incomplete Parts
's Search Service - Incomplete Parts.jpg
's Search Service - Incomplete Parts.jpg [ 183.69 KiB | Viewed 7360 times ]
Top
 Profile  
 
 Post subject: Re: Search Service showing huge amount of incomplete parts
PostPosted: Mon Feb 06, 2012 2:14 pm 

Joined: Thu Feb 27, 2003 5:57 pm
Posts: 4373
Maybe it is because of removing one feed 5 days ago, it appears astraweb has also problem with their headers like they have constantly missing article bodies at least in older posts.

I'll post updates in this thread, there is capability to redownload older headers, I need to change something in the code first to prevent too many users messages caused by header feed insonsistencies. I hope to finish all that within two days.


Top
 Profile  
 
 Post subject: Re: Search Service showing huge amount of incomplete parts
PostPosted: Mon Feb 06, 2012 6:43 pm 

Joined: Mon Apr 04, 2005 7:15 pm
Posts: 7
Hi Alex,

Thanks for your reply!

Just curious, could you please explain in a little bit more detail what's actually causing the reported problem? I understand that you removed a feed 5 days ago, but what kind of feed exactly? Do the currently existing feeds miss certain information, or is there just a mismatch between the provided information from the feeds and the header information sitting on some Usenet servers?

Is there maybe available a temporary solution for me as an end user or should I just be patient? ;-)

Thanks in advance!

Kind Regards,
Victor.


Top
 Profile  
 
 Post subject: Re: Search Service showing huge amount of incomplete parts
PostPosted: Thu Feb 09, 2012 1:15 pm 

Joined: Thu Feb 27, 2003 5:57 pm
Posts: 4373
I don't know, maybe astraweb had temporary problem with headers coming out of sync (gaps in article numbering when fetching headers at too frequent intervals) or it is something more permanent which got exposed when I removed the feed, I'm trying to clarify with them.

hdtv group (your cited posts from that group only?) I've redownloaded last 14 days (I removed failing feed 10 days ago, just added few more days for some case)

I'm also redownloading 14 days for all groups it should be over by tomorrow.

I've also added giganews as additional feed.

If you see something more incomplete let me know.


Top
 Profile  
 
 Post subject: Re: Search Service showing huge amount of incomplete parts
PostPosted: Thu Feb 09, 2012 1:31 pm 

Joined: Mon Apr 04, 2005 7:15 pm
Posts: 7
Hi Alex,

Great, thanks a lot for your time and efforts you spent on investigating and fixing this issue! Sure, I will keep an eye on all incomplete posts (if any). Nice one that you've also added giganews as an extra feed, now things should only get better! :-)

Kind Regards,
Victor.


Top
 Profile  
 
 Post subject: Re: Search Service showing huge amount of incomplete parts
PostPosted: Thu Feb 09, 2012 3:25 pm 

Joined: Mon Apr 04, 2005 7:15 pm
Posts: 7
It seems that alt.binaries.e-book.technical also suffered from missing parts.


Top
 Profile  
 
 Post subject: Re: Search Service showing huge amount of incomplete parts
PostPosted: Fri Feb 10, 2012 10:15 pm 

Joined: Thu Feb 27, 2003 5:57 pm
Posts: 4373
check, all should be ok now, i finished the update across all groups.

i solved the problem with astraweb, code i wrote earlier to handle low quality feeds clashed with astraweb way which is sometimes not to return headers after returning increased header range.


Top
 Profile  
 
 Post subject: Re: Search Service showing huge amount of incomplete parts
PostPosted: Fri Feb 10, 2012 10:34 pm 

Joined: Sun Nov 26, 2006 11:49 pm
Posts: 21
This answered the problem I incorrectly posted in the "Support" group, which I have deleted. Thanks very much.


Top
 Profile  
 
 Post subject: Re: Search Service showing huge amount of incomplete parts
PostPosted: Sat Feb 11, 2012 12:38 am 

Joined: Mon Apr 04, 2005 7:15 pm
Posts: 7
Hi Alex,

Thanks again for your time and efforts, nice to hear that you've solved the problem! :-)

Have a great weekend!

Kind Regards,
Victor.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 9 posts ] 

All times are UTC


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group